CURLのインストール

7月 12, 2011 · Posted in facebook, linux, PHP 
Post to Google Buzz
このエントリーをはてなブックマークに追加

facebookアプリを作ろうとfacebookSDKを読み込んでみる。

すると、下記のエラーが発生。
“Facebook needs the CURL PHP extension”

facebookSDKには”CURL”が必要らしい。
PHPのデフォルトではCURLは無効となっているため、再コンパイルして有効にする必要がある。

./configure --with-apxs2=/usr/local/apache2/bin/apxs\
 --enable-zend-multibyte\
 --enable-mbstring\
 --enable-mbregex\
 --with-curl=/usr/local/include/curl/curl.h

Apacheを再起動して、再度実行してみるとエラーが出なくなった。
facebookSDKを使うにはCURLが必須のようだ。

Comments

Leave a Reply